Wednesday, October 27, 2010

Computer Setup

So I had this old Gateway machine sitting here. It's a hand-me-down from my wife. It has it's issues but appears to be working okay with a new Ubuntu 10.04 install. EMC2 installed surprisingly easy. I was settling in for the long haul, expecting tweaks and hacks but no need at all. wiki provides an install script and that literally did everything!

So far so good. I had brought an old video card as I had read that integrated video cards can increase latency. The documentation states that anything below 15-20ms will be great. Anything in the 30ms will be ok, but might be slow. 100ms will not be any good.

I ran the HAL Latency test and the worst case jitter is 23189. Not brilliant but not bad.


Since I don't have stuff connected yet (stepper drivers boards coming tomorrow) I decided to get the datasheets for the steppers.

The X-axis stepper is a Mitsumi M35SP-11NK (the sheet says 25Ohms, the unit says 8 Ohms)
The Y-axis stepper is a Mitsumi MS35SP-9T (11 Ohm), for which I cannot find a data sheet.

The 11NK - 25Ohm appears to run on 12V or 24V. So I'll be better off starting considerably lower. Maybe even 6V... LM317 to the rescue.

Oh and of course I'll have to figure out how to hook up the stepper motors.

One thing I noticed is that the gears have a bit of slop. Meaning that when the stepper starts to turn, the belt doesn't move for about 2 or 3 steps. Since I'm new to all this, I asked ol' google about compensating for gear slop in EMC. Which quickly led me to the official term for this problem: "Backlash" and the remedy Backlash Compensation. Documented in the manual under axis configuration BACKLASH.

No comments:

Post a Comment